Startseite > Sonstiges > Absturz/Einfrieren bei Standby und Ruhezustand/Hibernate

Absturz/Einfrieren bei Standby und Ruhezustand/Hibernate

Mal was völlig unpolitisches – ein Tipp, der vielleicht auch anderen hilft: Mein Rechner stürzte beim Wechsel in den Standby-Modus oder in den Ruhezustand (Hibernate) oft ab bzw. fror ein. Manchmal zeigte er noch „Standby wird vorbereitet“ bzw. „Ruhezustand wird vorbereitet“ und blieb dann einfach stehen, oder er fror erst ein, nachdem er einen schwarzen Bildschirm angezeigt, aber den Bildschirm noch nicht ganz ausgeschaltet hatte. Beim Ruhezustand wurde der Fortschrittsbalken mit Windows-Logo nicht angezeigt, und in beiden Fällen war ein harter Reset fällig, sodass ich alle offenen Dateien verlor.

Die ganzen üblichen Maßnahmen hatte ich durch, ohne Erfolg:

  • Ruhezustand aus- und wieder einschalten, um die entsprechende Datei neu anzulegen
  • Treiberupdates (gibt es nicht mehr für das alte Gerät)
  • Diverse Microsoft-Hotfixes (es gibt wohl mindestens 3 Stück, siehe hier sowie hier und hier)
  • Festplatte auf Fehler gescannt (Dateisystem ok, keine defekten Sektoren, SMART-Werte perfekt) und defragmentiert (wobei das nicht wirklich eine Hilfsmaßnahme war, war einfach nur gerade fällig)
  • besondere Hardware hatte ich auch nicht angeschlossen gehabt, als es passierte (mit der die dran war hatte es früher immer geklappt)

Woran es lag, wusste ich nicht – mein System ist eine einzige riesige Toolsammlung, und so wie es aussieht installiert sich jedes bessere Tool auch gleich einen Treiber. Dazu noch ein TrueCrypt zur Systemverschlüsselung um das Chaos perfekt zu machen. (Nebenbei: Windows scheint ein echt robustes System zu sein, ich will ein Linux sehen was derart mit zusammengefrickelten Kernelmodulen zugemüllt ist und trotzdem noch ohne Kernel Panic – quasi ein Linux-Bluescreen – durchläuft.)

Schließlich habe ich im Geräte-Manager die erweiterte Ansicht eingeschaltet und fröhlich drauf los gelöscht. Das sollte man tunlichst nur machen, wenn man weiß, was man tut. Wenn man danebengreift, wird man es meist bereuen, wenn man Pech hat auch erst Wochen später, dafür umso mehr. Man sollte nicht wahllos löschen. Wer also keine Ahnung von seinem System hat, sollte dringend die Finger davon lassen. Jedenfalls habe ich die meisten „versteckten“ (also nicht mehr angeschlossenen) USB- und Eingabe/HID-Geräte (und noch einiges mehr) rausgeworfen, die ich vermutlich nicht mehr brauche (z. B. weil mir jemand kurz einen USB-Stick mit Daten geliehen hat). Ich schätze, es werden gut 100 Stück gewesen sein, die sich da angesammelt haben. Windows merkt sich nämlich jede Maus, jeden USB-Stick und überhaupt alles was man mal per USB anschließt, manchmal auch jedes mal neu wenn das Gerät an einem anderen Anschluss angeschlossen wird, und verschluckt sich scheinbar, wenn die Liste zu lang wird. Seit der Aufräumaktion läuft es jedenfalls einwandfrei und vermutlich auch  schneller als vorher.

  1. Pierre Kerchner
    2009-06-13 um 15:35 UTC

    Super super Tipp

    ich würde am liebsten 5 Euro spenden ;-)

    pierre

    • Jan
      2009-06-13 um 16:07 UTC

      Die Piratenpartei, der Datenschutzverein Foebud, der CCC, der Arbeitskreis Vorratsdatenspeicherung etc. freuen sich sicher über eine Spende, wem der Tipp also geholfen hat und etwas Geld loswerden möchte, kann dort definitiv was gutes tun!

      Ich möchte aber nochmal darauf hinweisen, dass das bei mir geholfen hat, aber der Fehler ab und zu wieder kommt (nach einiger Löscherei geht er dann wieder). Diese Hibernate-Fehler sind hartnäckig und kaum zu debuggen, kommen (und gehen teilweise auch) ohne ersichtlichen Grund. Ich benutze derzeit das Tool „devcon“ um Gerätelisten zu erstellen, damit ich dann die Listen von „klappt“ und „klappt nicht“ vergleichen kann. Aber ich befürchte dass es nicht ein bestimmter Treiber ist, sondern das Zusammenspiel von mehreren, die Anzahl oder Timing-Probleme (durch Entfernen der Geräte ändert sich das Timing dann) sein könnten.

  2. 2009-09-04 um 17:36 UTC

    Schöner Beitrag. Ich kann noch dazutragen, dass ich davon ausgehe, dass TrueCrypt direkt dran schuld ist. Ich weiss nur noch nicht, wie. Jedenfalls hab ich auf dem Notebook meines Chefs _exakt_ die gleiche Problematik. Ausser TrueCrypt sind kaum exotische Dinge auf dem frischen System istalliert. Nach decrypt des Systemlaufwerks noch keine Besserung. Nach Deinstallation von TrueCrypt ging es dann. Darauf hin habe ich wieder verschlüsselt und es lief auch bei einem Testversuch. Ich habe das Gerät dann als repariert abgegeben. Naja, nun steht es wieder hier. Als ich nun wusste, dass das Problem nur manchmal auftritt, hab ich mich ja erstmal von dem Ansatz mit TrueCrypt verabschiedet. Nun les ich es aber hier und nun bin ich sicher, es liegt an einer Kombination aus dem was Du beschreibst und TrueCrypt. Wenn mir was neues einfällt schreib ich es mal hierhin, weil dieser Beitrag der einzige ist, der das Problem exakt so schildert wie ich es gerade erlebe, auch wenn er schon älter ist:P

  3. Riesenauspuff
    2009-10-12 um 15:17 UTC

    Der Tipp ist gut, aber ich möchte ihn noch ergänzen.
    Hatte ihn nämlich bei meinem ASUS Eee (Windows XP Home) angewandt, nur um festzustellen, dass etwa zwei Wochen später der Spuk „Standby Mous wird vorbereitet“ wieder von vorne losging. Glücklicherweise hatte mir der Eee kurz vorher gemeldet, dass er ein paar automatische Windows-Updates durchgeführt hatte: die Updates hatten offenbar irgendwelche Hardwaretreiber zerschossen!
    Meine Abhilfe: (1) Systemsteuerung, automatische Windows Updates abschalten (2) Im WINDOWS-Verzeichnis in etwa ein Dutzend der jüngsten Ordner gehen, die mit $NtUninstall… beginnen, dort jeweils in Ordner spuninst rein und spuninst.exe ausführen: damit nimmt man die jüngsten Updates wieder zurück.
    (3) Im Gerätemanger wird dann durch gelbe Ausrufezeichen verraten, welche Gerätetreiber durch die Updates zerstört wurden.
    Bei mir war es sogar deutlicher: da sich der Mauszeiger nicht mehr bewegte, war zu folgern, dass durch die Updates die Treiber des Synaptic Zeigergeräts hin waren. Nach Anschluss einer USB-Maus und Reingucken im Gerätemanager bestätigte das bekannte gelbe Ausrufezeichen den Verdacht, habe darauf das Gerät neu installiert und seitdem läuft alles tadellos.
    Die ganze Update-Paranoia mache ich nicht mehr mit, automatische Updates bleiben slbstverständlich ausgeschaltet.

    • Jan
      2009-10-12 um 16:12 UTC

      Updates auszuschalten ist auch keine Lösung, sofern der Rechner am Netz hängt. Ich rate DRINGEND davon ab, da man nicht nur die Sicherheit des eigenen Rechners damit aufs Spiel setzt, sondern mit dem infizierten Rechner dann auch andere Leute belästigt (SPAM) oder gefährdet.

  1. No trackbacks yet.

Schreibe einen Kommentar

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s

%d Bloggern gefällt das: